Blackview User Forum

 
sbknutti
Topic Author
Posts: 2
Joined: Sun Feb 28, 2021 3:32 am

BV4900

Sun Feb 28, 2021 3:38 am

I just got my BV4900 today and I was all excited. Was excited. Now, not so much. Every time I plug the phone in to charge it, it shuts off. Then I discover after it sat and "charged" for 3 hours...it DID NOT CHARGE A BIT! I need some help here! Is there something I'm doing wrong? I got this to replace a Samsung J7 that kept telling me it had no space, even though it was empty. I've used cell phones and smart phones for years...but this has me stumped, unless I just got a bad phone. HELP PLEASE! This phone is also my work phone!
Stephen B. Knutti (Brad)
NRA Golden Eagle Member
Greenfield, IN. 46140
 
User avatar
blackview_admin
Posts: 8561
Joined: Mon Aug 17, 2015 3:30 am
Contact:

Re: BV4900

Tue Mar 02, 2021 7:27 am

sbknutti wrote:
I just got my BV4900 today and I was all excited. Was excited. Now, not so much. Every time I plug the phone in to charge it, it shuts off. Then I discover after it sat and "charged" for 3 hours...it DID NOT CHARGE A BIT! I need some help here! Is there something I'm doing wrong? I got this to replace a Samsung J7 that kept telling me it had no space, even though it was empty. I've used cell phones and smart phones for years...but this has me stumped, unless I just got a bad phone. HELP PLEASE! This phone is also my work phone!

Hello, have you tried to use another USB to charge it? Can you try to charge it with another USB to verify it?

Who is online

Users browsing this forum: No registered users and 1 guest