Blackview User Forum

 
hristovski
Topic Author
Posts: 29
Joined: Mon Aug 01, 2016 5:53 pm
Location: Macedonia

Widgets not working after restart

Mon Feb 10, 2020 4:03 pm

I have few widgets on the home screen, but after a restart of the phone, they either don't work or they disappear...
I think that the default ones from google work, even after restart. I also waited for some time in case they are not finished loading, but still no.
After I manually start the applications, some widgets start working again, but some don't... Only removing and adding them again, works.

P.S. Some widgets are: Smart AudioBook Reader, ColorNote, Water Drink Reminder, etc.
 
User avatar
serg2327
Posts: 65
Joined: Wed Jul 27, 2016 2:40 am
Location: odessa

Re: Widgets not working after restart

Tue Feb 11, 2020 5:46 am

This problem is due to the fact that in all firmware on all smartphones the application autorun is disabled
On all smartphones blackview where Android 8 or Android 9 is installed, the autorun of third-party applications is blocked everywhere!
There are complaints about this problem on absolutely all topics, but company representatives either do not respond or advise frank nonsense, because they understand nothing of this!
In this regard, the question begs for representatives of the company, you are not tired of reading the same questions on all topics? When will you start to respond? when will you start collecting bug lists and sending them to engineers? all smartphones have the same problems !!
PS
This problem is solved very easily with root access. You just need to fix one line in the build.prop file:

ro.freeme_freemanager=1
ro.hct_autostart_manager=1

In these lines you need to change 1 to 0

Explain to me comrade representatives, how many more years will your smartphone users suffer?
Is it really so hard to fix so that the application autorun applications out of the box work on the smartphone?
 
Honu
Posts: 9
Joined: Tue Feb 04, 2020 11:20 am

Re: Widgets not working after restart

Wed Feb 12, 2020 4:37 pm

Thanks Serg .. my widgets also got problems, Build.prop updated .. thanks
 
davespagnol
Posts: 2
Joined: Thu May 07, 2020 8:08 pm

Re: Widgets not working after restart

Thu May 07, 2020 8:15 pm

serg2327 wrote:
This problem is due to the fact that in all firmware on all smartphones the application autorun is disabled
On all smartphones blackview where Android 8 or Android 9 is installed, the autorun of third-party applications is blocked everywhere!
There are complaints about this problem on absolutely all topics, but company representatives either do not respond or advise frank nonsense, because they understand nothing of this!
In this regard, the question begs for representatives of the company, you are not tired of reading the same questions on all topics? When will you start to respond? when will you start collecting bug lists and sending them to engineers? all smartphones have the same problems !!
PS
This problem is solved very easily with root access. You just need to fix one line in the build.prop file:

ro.freeme_freemanager=1
ro.hct_autostart_manager=1

In these lines you need to change 1 to 0

Explain to me comrade representatives, how many more years will your smartphone users suffer?
Is it really so hard to fix so that the application autorun applications out of the box work on the smartphone?

Did you root an A80 Pro? How? Installing TWRP via SP Flash Tool results in the original recovery image being written back. Installing TWRP via Fastboot results in the phone resetting to Factory Settings. It's obvious that all the "experts" who write web sites with instructions are just using generic instructions.
 
davespagnol
Posts: 2
Joined: Thu May 07, 2020 8:08 pm

Re: Widgets not working after restart

Wed May 13, 2020 7:15 pm

It would be a nice idea if you could make a change to the phone's operating system, so that all the apps that a user puts in the "White List" will be started in the background on bootup. That would give the user ultimate control over the use of the phone's memory.

I did try to root the phone, but all attempts failed. Most of the "on-line experts" with their web sites are trying to adapt from generic instructions, and copy each other. And none of their methods work.
 
User avatar
blackview_admin
Posts: 8236
Joined: Mon Aug 17, 2015 3:30 am
Contact:

Re: Widgets not working after restart

Thu May 14, 2020 6:35 am

davespagnol wrote:
serg2327 wrote:
This problem is due to the fact that in all firmware on all smartphones the application autorun is disabled
On all smartphones blackview where Android 8 or Android 9 is installed, the autorun of third-party applications is blocked everywhere!
There are complaints about this problem on absolutely all topics, but company representatives either do not respond or advise frank nonsense, because they understand nothing of this!
In this regard, the question begs for representatives of the company, you are not tired of reading the same questions on all topics? When will you start to respond? when will you start collecting bug lists and sending them to engineers? all smartphones have the same problems !!
PS
This problem is solved very easily with root access. You just need to fix one line in the build.prop file:

ro.freeme_freemanager=1
ro.hct_autostart_manager=1

In these lines you need to change 1 to 0

Explain to me comrade representatives, how many more years will your smartphone users suffer?
Is it really so hard to fix so that the application autorun applications out of the box work on the smartphone?

Did you root an A80 Pro? How? Installing TWRP via SP Flash Tool results in the original recovery image being written back. Installing TWRP via Fastboot results in the phone resetting to Factory Settings. It's obvious that all the "experts" who write web sites with instructions are just using generic instructions.

Hello, if you have any questions about the phone, please contact our after-sale department: support02@blackview.hk
 
User avatar
serg2327
Posts: 65
Joined: Wed Jul 27, 2016 2:40 am
Location: odessa

Re: Widgets not working after restart

Sun May 24, 2020 12:41 pm

davespagnol wrote:
Did you root an A80 Pro? How? Installing TWRP via SP Flash Tool results in the original recovery image being written back. Installing TWRP via Fastboot results in the phone resetting to Factory Settings. It's obvious that all the "experts" who write web sites with instructions are just using generic instructions.


Have you tried using the search ??
Do you know about the existence of the 4pda resource?
So there a root has long been received and ported twrp
ссылка1: 
ссылка2:
PS/
I don’t have this smartphone and never have,
I have not been working with Blackview for a long time.
Once a representative of Blackview company provided me with smartphones (new items) and I was a freelance employee, supervised the topics on the 4pda Russian-language forum, helped the owners of devices, did it completely disinterestedly ..
That is why most of the BV devices have root / TWRP and much more useful.
Over time, I began to strain topics, because there were more and more smartphones, and I refused to curate topics.
Now, as far as I know, Blackview companies are not at all interested in such employees. Everything is geared towards advertising .- "For more advertising, sell more expensive and forget in a month"
 
marek85
Posts: 7
Joined: Wed Mar 04, 2020 12:42 pm

Re: Widgets not working after restart

Wed May 27, 2020 1:52 pm

serg2327 wrote:
This problem is due to the fact that in all firmware on all smartphones the application autorun is disabled
On all smartphones blackview where Android 8 or Android 9 is installed, the autorun of third-party applications is blocked everywhere!
There are complaints about this problem on absolutely all topics, but company representatives either do not respond or advise frank nonsense, because they understand nothing of this!
In this regard, the question begs for representatives of the company, you are not tired of reading the same questions on all topics? When will you start to respond? when will you start collecting bug lists and sending them to engineers? all smartphones have the same problems !!
PS
This problem is solved very easily with root access. You just need to fix one line in the build.prop file:

ro.freeme_freemanager=1
ro.hct_autostart_manager=1

In these lines you need to change 1 to 0

Explain to me comrade representatives, how many more years will your smartphone users suffer?
Is it really so hard to fix so that the application autorun applications out of the box work on the smartphone?

hi serg. does build.prop change to default after factory reset?
 
User avatar
blackview_admin
Posts: 8236
Joined: Mon Aug 17, 2015 3:30 am
Contact:

Re: Widgets not working after restart

Mon Sep 21, 2020 7:09 am

hristovski wrote:
Hello,

I updated the phone to Android 10 (A80Pro_EEA_M557B_V1.0_20200815V05) and we've got the same problem on Android 10 too.
None of the applications autostart after restarting the phone.

Sorry for this inconvenience caused to you. Please contact the after-sale department to get them solution: support02@blackview.hk
 
buffalo75
Posts: 2
Joined: Tue Nov 17, 2020 5:36 pm

Re: Widgets not working after restart

Tue Nov 17, 2020 6:04 pm

Does anyone know whether this problem with the widgets not loading after a restart of the phone will also occur on the BV6300 with Android 10 pre-installed?

I encountered it on a BV9900 (without Pro) with Android 9 I just bought. Affected widgets in my case are for example Battery Monitor Pro, DiskInfo PRO, DIGI Clock Plus, LunaSolCal.. I sent an enquiry with detailed description and even screenshots to the support email mentioned here in this thread. I got a quick answer but that only was "It is normal, the phone can't support open app automatically, after reboot, you need to set again." which is not satisfactory, as I see no reason for that behaviour of the phone. The only other Android 9 device I have is a tablet from another brand where the widgets start correctly after a reboot.

So I was wondering if the problem is fixed on Blackviews Android 10 devices.

Who is online

Users browsing this forum: No registered users and 1 guest