Blackview User Forum

Topic Author
Posts: 1
Joined: Sat Oct 19, 2019 9:23 am

HELP! Phone cannot start after flashing with SP Flash Tool

Sat Oct 19, 2019 9:35 am

Before I attempted to re-flash with SP Flash tool, my phone was having issues starting up. I tried to factory reset it but it kept showing mounting errors. I even tried to use the mount option in the recovery menu and it still shows that same error. Deleted the partition cache, no luck. Frustrated and all, I decided to try and flash it with SP Flash Tool. The first time around, it looked like it did something, but after the checkmark part when it tells you are done, the phone simply shows a black screen. However, the PC still detects the device like normal, but it constantly connects and disconnects.

Used this ROM:

Hours of researching on the internet, if you hold the volume down or up and plugging the USB, it should enter in a state where you can flash ROMs using the SP Flash tool. Device manager picks it up as MediaTek DA USB VCOM (Android) (COM8). No matter what I do, pressing different combinations or re-downloading the same ROM, whenever i start flashing with SP Flash tool, it either spits out an error or you press Start but nothing happens. 

So what now? Is my phone a total brick at this point? So frustrated that none of the recovery methods were even working and having to resort to this tool as a final resort didn't help at all.

Who is online

Users browsing this forum: No registered users and 1 guest