Blackview User Forum

 
MAil20
Topic Author
Posts: 1
Joined: Sat Mar 28, 2020 12:38 am

Blackview A10 not charging properly

Sat Mar 28, 2020 1:14 am

So I'm having some problems recently when it comes to charging my Blackview A10. Have had it since August last year and had next to no problems with it until recently. No matter what cable I use to charge it with, it either charges for a bit and then stops, or charges backwards for some reason (9% will go down to 8%, then 7% etc...), or doesn't charge at all. Sometimes it will charge properly but it's getting kind of rare for that to happen and it won't be all the way before it either stops or goes backwards. So, what is happening here? How do I remedy this problem??? 
 
User avatar
blackview_admin
Posts: 7441
Joined: Mon Aug 17, 2015 3:30 am
Contact:

Re: Blackview A10 not charging properly

Sat Mar 28, 2020 5:44 am

MAil20 wrote:
So I'm having some problems recently when it comes to charging my Blackview A10. Have had it since August last year and had next to no problems with it until recently. No matter what cable I use to charge it with, it either charges for a bit and then stops, or charges backwards for some reason (9% will go down to 8%, then 7% etc...), or doesn't charge at all. Sometimes it will charge properly but it's getting kind of rare for that to happen and it won't be all the way before it either stops or goes backwards. So, what is happening here? How do I remedy this problem??? 

The charge port is broken. It need fixed.
Contact your seller or our after-sales directly.
After-sales email: support02@blackview.hk

Who is online

Users browsing this forum: No registered users and 1 guest