Blackview User Forum

 
Ucooki8
Topic Author
Posts: 1
Joined: Sun Jun 10, 2018 1:14 pm

Charging problems.

Sun Jun 10, 2018 1:25 pm

I have had my A7 for around 4 months now and there have been no issues apart from now. The issue is that it is charging very slow and sometimes gets stuck at 20% and if I'm lucky at 30%. I have the same battery that is suppllied and still use the Blackview cable and adapter in a UK wall outlet. The charger seems to only work in certain positions and I am not sure why since I rarely take the phone outside and when it is charging I do not forcefulle put the cable in the port.I was wondering if I am able to get a replacment A7 for free to swap for the one I have since I have no money to replace the phone or to get it repaired. I really enjoy this phone and its a shame I can't use it because its always out of battery.

Thank you. :)
 
blackview_admin
Posts: 5254
Joined: Mon Aug 17, 2015 3:30 am
Contact:

Re: Charging problems.

Mon Jun 11, 2018 3:38 pm

Can you please test another charger and cable? I need to rule out if it's a problem regarding the cable or the phone usb port.
 
overtonesun
Posts: 1
Joined: Mon Jul 09, 2018 12:05 pm

Re: Charging problems.

Mon Jul 09, 2018 12:13 pm

Hi, I have exactly the same issue about charging problems in Blackview A7. 
I've tried many different perfectly working cables and it didn't work.
It seems the phone has a faulty port that losts connectivity. 
I have the phone since January 2018. It worked fine for 6 months and then the charging problems appeared. 
There were no forced uses nor any unusual use that could damage the phone. It suddenly started giving those problems. 
Do you think it's a firmware issue or hardware? I still have it within the warranty period, should I send it for repair? 
Hope you can answer these questions, thank you. 
 
blackview_admin
Posts: 5254
Joined: Mon Aug 17, 2015 3:30 am
Contact:

Re: Charging problems.

Wed Jul 11, 2018 8:39 am

overtonesun wrote:
Hi, I have exactly the same issue about charging problems in Blackview A7. 
I've tried many different perfectly working cables and it didn't work.
It seems the phone has a faulty port that losts connectivity. 
I have the phone since January 2018. It worked fine for 6 months and then the charging problems appeared. 
There were no forced uses nor any unusual use that could damage the phone. It suddenly started giving those problems. 
Do you think it's a firmware issue or hardware? I still have it within the warranty period, should I send it for repair? 
Hope you can answer these questions, thank you. 

Yeah, i suggest you to send it back to be repaired or replaced.

Who is online

Users browsing this forum: No registered users and 1 guest